summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorUwe Hermann <uwe@hermann-uwe.de>2014-01-17 17:56:26 +0100
committerUwe Hermann <uwe@hermann-uwe.de>2014-01-17 18:03:27 +0100
commite8ce01860673214bae97a6b793a7f55e13128dba (patch)
tree2c6e365463e1a6d5935786ecf8551334734e28cd /configure.ac
parent91c78794d872dcac55f93ecbae1e28cec1ca6bf6 (diff)
downloadlibsigrokdecode-e8ce01860673214bae97a6b793a7f55e13128dba.tar.gz
libsigrokdecode-e8ce01860673214bae97a6b793a7f55e13128dba.zip
configure.ac: Drop obsolete MinGW Python3 workaround.
We just use dummy/fake python3.pc files on Windows so that the usual pkg-config mechanism works there as well.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 0 insertions, 10 deletions
diff --git a/configure.ac b/configure.ac
index f7bf20d..12de743 100644
--- a/configure.ac
+++ b/configure.ac
@@ -110,16 +110,6 @@ PKG_CHECK_MODULES([python3], [python3 >= 3.0],
[CPPFLAGS_PYTHON="$CPPFLAGS_PYTHON $python30_CFLAGS";
LDFLAGS_PYTHON="$LDFLAGS_PYTHON $python30_LIBS"],
)])])])])
-case "$build" in
-*mingw*)
- # We currently hardcode the paths to the Python 3.2 default install
- # location as there's no 'python-config' script on Windows, it seems.
- # Note: We add both the /c/ and c:/ syntax (needed for cmake).
- AC_MSG_WARN([using hardcoded Python3 configuration on MinGW])
- CPPFLAGS_PYTHON="-I/c/Python32/include -Ic:/Python32/include"
- LDFLAGS_PYTHON="-L/c/Python32/libs -Lc:/Python32/libs -lpython32"
- ;;
-esac
AC_SUBST(CPPFLAGS_PYTHON)
AC_SUBST(LDFLAGS_PYTHON)