summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorUwe Hermann <uwe@hermann-uwe.de>2014-01-17 17:56:08 +0100
committerUwe Hermann <uwe@hermann-uwe.de>2014-01-17 17:58:17 +0100
commit91c78794d872dcac55f93ecbae1e28cec1ca6bf6 (patch)
tree65d310ed223802ef7097c82bdd4f11b484fca20f /configure.ac
parent8eafa2613d2541e934a04874cd35cbc944c3168b (diff)
downloadlibsigrokdecode-91c78794d872dcac55f93ecbae1e28cec1ca6bf6.tar.gz
libsigrokdecode-91c78794d872dcac55f93ecbae1e28cec1ca6bf6.zip
configure.ac: Check for all known Python3 pkg-config names.
Even when using pkg-config not all distro/platform specific issues are transparent, unfortunately. On some systems the pkg-config file is named "python3.pc" on others it's versioned, e.g. "python-3.2.pc". See also: http://sigrok.org/wiki/Libsigrokdecode/Python This should fix the build on e.g. FreeBSD, NetBSD, Mac OS X (some versions), and possibly various Linux distros, e.g. Gentoo. Also, drop manual AC_MSG_ERROR() and let PKG_CHECK_MODULES() output a more verbose and standardized error message if Python 3 is not found.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac30
1 files changed, 21 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index 2d480ee..f7bf20d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -88,12 +88,28 @@ build_runtc="yes"
AM_PATH_GLIB_2_0([2.24.0],
[CFLAGS="$CFLAGS $GLIB_CFLAGS"; LIBS="$LIBS $GLIB_LIBS"])
-# Python support. We require at least Python >= 3.0.
+# Python 3 is always needed.
+# Note: We need to try a few different variants, since some systems have a
+# python3.pc file, others have a python-3.3.pc file, and so on.
+# See also: http://sigrok.org/wiki/Libsigrokdecode/Python
CPPFLAGS_PYTHON=""
LDFLAGS_PYTHON=""
PKG_CHECK_MODULES([python3], [python3 >= 3.0],
- [have_python3="yes"; CPPFLAGS_PYTHON="$python3_CFLAGS";
- LDFLAGS_PYTHON="$python3_LIBS"], [have_python3="no"])
+ [CPPFLAGS_PYTHON="$CPPFLAGS_PYTHON $python3_CFLAGS";
+ LDFLAGS_PYTHON="$LDFLAGS_PYTHON $python3_LIBS"],
+[PKG_CHECK_MODULES([python33], [python-3.3 >= 3.0],
+ [CPPFLAGS_PYTHON="$CPPFLAGS_PYTHON $python33_CFLAGS";
+ LDFLAGS_PYTHON="$LDFLAGS_PYTHON $python33_LIBS"],
+[PKG_CHECK_MODULES([python32], [python-3.2 >= 3.0],
+ [CPPFLAGS_PYTHON="$CPPFLAGS_PYTHON $python32_CFLAGS";
+ LDFLAGS_PYTHON="$LDFLAGS_PYTHON $python32_LIBS"],
+[PKG_CHECK_MODULES([python31], [python-3.1 >= 3.0],
+ [CPPFLAGS_PYTHON="$CPPFLAGS_PYTHON $python31_CFLAGS";
+ LDFLAGS_PYTHON="$LDFLAGS_PYTHON $python31_LIBS"],
+[PKG_CHECK_MODULES([python30], [python-3.0 >= 3.0],
+ [CPPFLAGS_PYTHON="$CPPFLAGS_PYTHON $python30_CFLAGS";
+ LDFLAGS_PYTHON="$LDFLAGS_PYTHON $python30_LIBS"],
+)])])])])
case "$build" in
*mingw*)
# We currently hardcode the paths to the Python 3.2 default install
@@ -103,11 +119,6 @@ case "$build" in
CPPFLAGS_PYTHON="-I/c/Python32/include -Ic:/Python32/include"
LDFLAGS_PYTHON="-L/c/Python32/libs -Lc:/Python32/libs -lpython32"
;;
-*)
- if test x"$have_python3" = xno; then
- AC_MSG_ERROR([python3 not found])
- fi
- ;;
esac
AC_SUBST(CPPFLAGS_PYTHON)
AC_SUBST(LDFLAGS_PYTHON)
@@ -121,7 +132,8 @@ PKG_CHECK_MODULES([check], [check >= 0.9.4],
LIBS="$LIBS $check_LIBS"], [have_check="no"])
AM_CONDITIONAL(HAVE_CHECK, test x"$have_check" = "xyes")
-# Protocol decoder test framework
+# libsigrok is optional (only used for the protocol decoder test framework).
+# Disable if not found.
PKG_CHECK_MODULES([libsigrok], [libsigrok >= 0.2.0],
[LIBSIGROK_CFLAGS="$libsigrok_CFLAGS"; LIBSIGROK_LIBS="$libsigrok_LIBS"],
[build_runtc="no"])