summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEvangelos Foutras <evangelos@foutrelis.com>2020-12-03 19:17:00 +0200
committerGerhard Sittig <gerhard.sittig@gmx.net>2021-12-21 11:24:40 +0100
commita6a5e2c8b0e9ecf5d69d0c237c8e8b717b82b36f (patch)
tree757be72fbb8c2e282f7325a799b317fbe47d73be /configure.ac
parentc4c10b89396fe21a622b8c38dd5815a496b007bf (diff)
downloadlibsigrokdecode-a6a5e2c8b0e9ecf5d69d0c237c8e8b717b82b36f.tar.gz
libsigrokdecode-a6a5e2c8b0e9ecf5d69d0c237c8e8b717b82b36f.zip
configure.ac: Use python3-embed.pc as a fallback
This provides some future-proofing against newer Python versions.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index b8841f8..c1314bb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -100,7 +100,7 @@ SR_PKG_CHECK_SUMMARY([srd_pkglibs_summary])
# first, since usually only that variant will add "-lpython3.8".
# https://docs.python.org/3/whatsnew/3.8.html#debug-build-uses-the-same-abi-as-release-build
SR_PKG_CHECK([python3], [SRD_PKGLIBS],
- [python-3.10-embed], [python-3.9-embed], [python-3.8-embed], [python-3.8 >= 3.8], [python-3.7 >= 3.7], [python-3.6 >= 3.6], [python-3.5 >= 3.5], [python-3.4 >= 3.4], [python-3.3 >= 3.3], [python-3.2 >= 3.2], [python3 >= 3.2])
+ [python-3.10-embed], [python-3.9-embed], [python-3.8-embed], [python3-embed], [python-3.8 >= 3.8], [python-3.7 >= 3.7], [python-3.6 >= 3.6], [python-3.5 >= 3.5], [python-3.4 >= 3.4], [python-3.3 >= 3.3], [python-3.2 >= 3.2], [python3 >= 3.2])
AS_IF([test "x$sr_have_python3" = xno],
[AC_MSG_ERROR([Cannot find Python 3 development headers.])])