summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSoeren Apel <soeren@apelpie.net>2021-12-20 19:36:39 +0100
committerSoeren Apel <soeren@apelpie.net>2021-12-20 19:36:39 +0100
commitc4c10b89396fe21a622b8c38dd5815a496b007bf (patch)
treeb2647b9e124bda1632baa3d5131d1d665d5ad288 /configure.ac
parent82f3f4d4163ffba003a49a5c7f1f6966f132bbb8 (diff)
downloadlibsigrokdecode-c4c10b89396fe21a622b8c38dd5815a496b007bf.tar.gz
libsigrokdecode-c4c10b89396fe21a622b8c38dd5815a496b007bf.zip
configure: Add python 3.10 support
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 2917cb3..b8841f8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -100,7 +100,7 @@ SR_PKG_CHECK_SUMMARY([srd_pkglibs_summary])
# first, since usually only that variant will add "-lpython3.8".
# https://docs.python.org/3/whatsnew/3.8.html#debug-build-uses-the-same-abi-as-release-build
SR_PKG_CHECK([python3], [SRD_PKGLIBS],
- [python-3.9-embed], [python-3.8-embed], [python-3.8 >= 3.8], [python-3.7 >= 3.7], [python-3.6 >= 3.6], [python-3.5 >= 3.5], [python-3.4 >= 3.4], [python-3.3 >= 3.3], [python-3.2 >= 3.2], [python3 >= 3.2])
+ [python-3.10-embed], [python-3.9-embed], [python-3.8-embed], [python-3.8 >= 3.8], [python-3.7 >= 3.7], [python-3.6 >= 3.6], [python-3.5 >= 3.5], [python-3.4 >= 3.4], [python-3.3 >= 3.3], [python-3.2 >= 3.2], [python3 >= 3.2])
AS_IF([test "x$sr_have_python3" = xno],
[AC_MSG_ERROR([Cannot find Python 3 development headers.])])