summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorUwe Hermann <uwe@hermann-uwe.de>2014-01-03 17:41:24 +0100
committerUwe Hermann <uwe@hermann-uwe.de>2014-01-03 17:41:24 +0100
commit6af04d5a36a47b11dcf10bb629105600aa5a66eb (patch)
treed48252f45592e9fa900cb21bd14a57c7dc757248 /configure.ac
parent7d54fe300d9e3375f731abcd16d637e470ef3976 (diff)
downloadlibsigrokdecode-6af04d5a36a47b11dcf10bb629105600aa5a66eb.tar.gz
libsigrokdecode-6af04d5a36a47b11dcf10bb629105600aa5a66eb.zip
Link against libm to avoid Python related linking errors.
The python3-config script reported "-lm" as linker option previously, but we switched to using pkg-config (among other things for cross-compile support) which doesn't report "-lm" though (this is a common behaviour across multiple distros and OSes).
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index deedd5c..2d480ee 100644
--- a/configure.ac
+++ b/configure.ac
@@ -112,6 +112,9 @@ esac
AC_SUBST(CPPFLAGS_PYTHON)
AC_SUBST(LDFLAGS_PYTHON)
+# Link against libm, this is required (among other things) by Python.
+AC_SEARCH_LIBS([pow], [m])
+
# The Check unit testing framework is optional. Disable if not found.
PKG_CHECK_MODULES([check], [check >= 0.9.4],
[have_check="yes"; CFLAGS="$CFLAGS $check_CFLAGS";