summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMarcus Comstedt <marcus@mc.pp.se>2014-01-02 12:43:34 +0100
committerMarcus Comstedt <marcus@mc.pp.se>2014-01-02 12:43:34 +0100
commit7d54fe300d9e3375f731abcd16d637e470ef3976 (patch)
tree400a6ad5bf867f94435b945afa0928dc91ec8365 /configure.ac
parent0c0368d0fc4ba737716326b87e99d70397134d38 (diff)
downloadlibsigrokdecode-7d54fe300d9e3375f731abcd16d637e470ef3976.tar.gz
libsigrokdecode-7d54fe300d9e3375f731abcd16d637e470ef3976.zip
configure.ac: Use pkg-config to check for python
Using python-config does not work when cross-compiling, since it can only be run on the host system.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 5 insertions, 13 deletions
diff --git a/configure.ac b/configure.ac
index 88855e0..deedd5c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -89,10 +89,11 @@ AM_PATH_GLIB_2_0([2.24.0],
[CFLAGS="$CFLAGS $GLIB_CFLAGS"; LIBS="$LIBS $GLIB_LIBS"])
# Python support. We require at least Python >= 3.0.
-AC_ARG_VAR([PYTHON3_CONFIG], [path to python3-config utility])
-AC_CHECK_PROGS([PYTHON3_CONFIG], [python3-config python3.3-config python-config-3.3 python3.2-config python-config-3.2 python3.1-config python-config-3.1 python3.0-config python-config-3.0])
CPPFLAGS_PYTHON=""
LDFLAGS_PYTHON=""
+PKG_CHECK_MODULES([python3], [python3 >= 3.0],
+ [have_python3="yes"; CPPFLAGS_PYTHON="$python3_CFLAGS";
+ LDFLAGS_PYTHON="$python3_LIBS"], [have_python3="no"])
case "$build" in
*mingw*)
# We currently hardcode the paths to the Python 3.2 default install
@@ -103,17 +104,8 @@ case "$build" in
LDFLAGS_PYTHON="-L/c/Python32/libs -Lc:/Python32/libs -lpython32"
;;
*)
- # We know that Linux has 'python3-config'.
- # On Darwin, Macports has python3.x-config, fink has python3-config.
- # Mac OS X (Snow Leopard) ships with 'python-config' per default, but
- # that's Python 2.x, so not useful for us.
- # Everything else is untested, we just hope some $PYTHON3_CONFIG
- # (i.e., any of the tools we check for above) is available.
- if test -n "$PYTHON3_CONFIG"; then
- CPPFLAGS_PYTHON="$($PYTHON3_CONFIG --includes)"
- LDFLAGS_PYTHON="$($PYTHON3_CONFIG --ldflags)"
- else
- AC_MSG_ERROR([python3-config not found])
+ if test x"$have_python3" = xno; then
+ AC_MSG_ERROR([python3 not found])
fi
;;
esac