summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDaniel Elstner <daniel.kitta@gmail.com>2015-08-26 14:07:39 +0200
committerDaniel Elstner <daniel.kitta@gmail.com>2015-08-26 14:07:39 +0200
commit7614222ca6cc73aae478d0ed659c0bcedfee4cc3 (patch)
tree0e2cb59a51d1bcc752008bdeb55c54f30f6e56c8 /Makefile.am
parenta654ef6e407f1f914a6ec9b104a5e4cf9b84524c (diff)
downloadlibsigrokdecode-7614222ca6cc73aae478d0ed659c0bcedfee4cc3.tar.gz
libsigrokdecode-7614222ca6cc73aae478d0ed659c0bcedfee4cc3.zip
Build: Define feature test macro _DEFAULT_SOURCE
This basically makes glibc expose the same set of features as if gcc was invoked without any restricting -std=c* option. Unlike _GNU_SOURCE however, it does not enable GNU-specific extensions. So, with this macro defined the behavior of Linux with glibc should match that of other platforms.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 0515e80..873883e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -23,7 +23,7 @@ AM_LIBTOOLFLAGS = --silent
MAKEFLAGS = --no-print-directory
DECODERS_DIR = $(pkgdatadir)/decoders
-AM_CPPFLAGS = -D_POSIX_C_SOURCE=200112L -DDECODERS_DIR='"$(DECODERS_DIR)"'
+AM_CPPFLAGS = -D_DEFAULT_SOURCE -DDECODERS_DIR='"$(DECODERS_DIR)"'
# The tests CFLAGS are a superset of the libsigrokdecode CFLAGS.
AM_CFLAGS = $(SRD_EXTRA_CFLAGS) $(SRD_WFLAGS) $(TESTS_CFLAGS)
@@ -70,7 +70,7 @@ tests_main_SOURCES = \
tests/inst.c \
tests/session.c
-tests_main_CPPFLAGS = -D_POSIX_C_SOURCE=200112L -DDECODERS_DIR='"$(abs_top_srcdir)/decoders"'
+tests_main_CPPFLAGS = -D_DEFAULT_SOURCE -DDECODERS_DIR='"$(abs_top_srcdir)/decoders"'
tests_main_LDADD = libsigrokdecode.la $(SRD_EXTRA_LIBS) $(TESTS_LIBS)
MAINTAINERCLEANFILES = ChangeLog