summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDaniel Elstner <daniel.kitta@gmail.com>2015-08-26 13:01:16 +0200
committerDaniel Elstner <daniel.kitta@gmail.com>2015-08-26 13:01:16 +0200
commita654ef6e407f1f914a6ec9b104a5e4cf9b84524c (patch)
tree7d7f8865afaff148c57d022ab741a4d26fe2f6e1 /Makefile.am
parent051d71c2b2851a3bcee29f46f7c7027a2edbc568 (diff)
downloadlibsigrokdecode-a654ef6e407f1f914a6ec9b104a5e4cf9b84524c.tar.gz
libsigrokdecode-a654ef6e407f1f914a6ec9b104a5e4cf9b84524c.zip
Build: Use TESTS prefix instead of CHECK for flag variables
In order to avoid confusion of the flags-gathering pkg-config result with the actual test for the availability of "check", change the pkg-config output variable prefix from CHECK to TESTS.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 0d33f53..0515e80 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -25,8 +25,8 @@ MAKEFLAGS = --no-print-directory
DECODERS_DIR = $(pkgdatadir)/decoders
AM_CPPFLAGS = -D_POSIX_C_SOURCE=200112L -DDECODERS_DIR='"$(DECODERS_DIR)"'
-# The check CFLAGS are a superset of the libsigrokdecode CFLAGS.
-AM_CFLAGS = $(SRD_EXTRA_CFLAGS) $(SRD_WFLAGS) $(CHECK_CFLAGS)
+# The tests CFLAGS are a superset of the libsigrokdecode CFLAGS.
+AM_CFLAGS = $(SRD_EXTRA_CFLAGS) $(SRD_WFLAGS) $(TESTS_CFLAGS)
lib_LTLIBRARIES = libsigrokdecode.la
@@ -71,7 +71,7 @@ tests_main_SOURCES = \
tests/session.c
tests_main_CPPFLAGS = -D_POSIX_C_SOURCE=200112L -DDECODERS_DIR='"$(abs_top_srcdir)/decoders"'
-tests_main_LDADD = libsigrokdecode.la $(SRD_EXTRA_LIBS) $(CHECK_LIBS)
+tests_main_LDADD = libsigrokdecode.la $(SRD_EXTRA_LIBS) $(TESTS_LIBS)
MAINTAINERCLEANFILES = ChangeLog