summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorUwe Hermann <uwe@hermann-uwe.de>2014-05-04 22:17:03 +0200
committerUwe Hermann <uwe@hermann-uwe.de>2014-05-04 22:25:45 +0200
commit1c0dbcc95b2e8e9a20279f0dab0eecd115be5484 (patch)
tree69754bab8d6a793f9f5e0c89351d321892c27403 /Makefile.am
parent0672779d5e3e128ef3f7ec932772ff6d65fcbc50 (diff)
downloadlibsigrokdecode-1c0dbcc95b2e8e9a20279f0dab0eecd115be5484.tar.gz
libsigrokdecode-1c0dbcc95b2e8e9a20279f0dab0eecd115be5484.zip
Fix 'make install' on OSes where 'python3' doesn't exist.
Sometimes the Python 3 executable is called just 'python3', sometimes it is called 'python3.4' and so on. Handle all cases transparently for the user. Before: $ make install /usr/bin/env: python3: No such file or directory After: $ make install python3.4 ./tools/install-decoders -i ./decoders -o [...] Installing 36 protocol decoders: [...]
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index c4a9d47..741720f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -89,8 +89,8 @@ dist-hook: ChangeLog
install-decoders:
$(MKDIR_P) $(DESTDIR)$(DECODERS_DIR)
- ${top_srcdir}/tools/install-decoders -i ${top_srcdir}/decoders \
- -o $(DESTDIR)$(DECODERS_DIR)
+ $(PYTHON3) ${top_srcdir}/tools/install-decoders \
+ -i ${top_srcdir}/decoders -o $(DESTDIR)$(DECODERS_DIR)
install-data-hook: install-decoders