summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 58ed252..ccaa2db 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -39,3 +39,11 @@ pkgconfig_DATA = libsigrokdecode.pc
EXTRA_DIST = Doxyfile
+MAINTAINERCLEANFILES = ChangeLog
+
+.PHONY: ChangeLog
+ChangeLog:
+ git --git-dir $(top_srcdir)/../.git log > ChangeLog || touch ChangeLog
+
+dist-hook: ChangeLog
+