summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorBert Vermeulen <bert@biot.com>2013-12-11 01:21:22 +0100
committerBert Vermeulen <bert@biot.com>2013-12-11 01:21:22 +0100
commitf8c88ebc5b33052de0b88690577af4611aa3709a (patch)
tree075e5a7ac9c81329558c8ac755206bafe645ecb1 /tests/Makefile.am
parentfbd226c3f70f20fdf3cbfd43a671bf2bcc5d23e6 (diff)
downloadlibsigrokdecode-f8c88ebc5b33052de0b88690577af4611aa3709a.tar.gz
libsigrokdecode-f8c88ebc5b33052de0b88690577af4611aa3709a.zip
Clean up runtc build.
This only compiles libsigrok into the one target that needs it, instead of slopping it all over the place.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 8086b9d..7841f05 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -41,6 +41,6 @@ endif
if HAVE_LIBSIGROK
bin_PROGRAMS = runtc
runtc_SOURCES = runtc.c
-runtc_CPPFLAGS = $(CPPFLAGS_PYTHON)
-runtc_LDFLAGS = -L/home/bert/sr/lib -lsigrok -lsigrokdecode
+runtc_CPPFLAGS = $(CPPFLAGS_PYTHON) $(LIBSIGROK_CFLAGS)
+runtc_LDFLAGS = $(LIBSIGROK_LIBS) -L$(top_builddir) -lsigrokdecode
endif