summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorBert Vermeulen <bert@biot.com>2013-12-10 17:17:38 +0100
committerBert Vermeulen <bert@biot.com>2013-12-10 17:22:24 +0100
commitfbd226c3f70f20fdf3cbfd43a671bf2bcc5d23e6 (patch)
tree7372a8e8b359b38a1a542a16fe14dd9058d5bded /tests/Makefile.am
parent4d2c7619ec72728dd01999f20ef1004e018d18a4 (diff)
downloadlibsigrokdecode-fbd226c3f70f20fdf3cbfd43a671bf2bcc5d23e6.tar.gz
libsigrokdecode-fbd226c3f70f20fdf3cbfd43a671bf2bcc5d23e6.zip
Add protocol decoder testing framework.
This adds a tool in the tests directory, called pdtest. It uses the "test/" directory in every PD directory, if present, to run the PD against dumps found in the sigrok-dumps repository, and compares the output against ".output" files in the "test/" directory. The file "test/test.conf" is used to configure which tests to run. A separate tool (tests/runtc.c) is used to run the actual decoding and report output. To get an overview of the options, run tests/pdtest without any options.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index b1ac2bf..8086b9d 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -19,7 +19,6 @@
##
if HAVE_CHECK
-
TESTS = check_main
check_PROGRAMS = ${TESTS}
@@ -37,5 +36,11 @@ check_main_CFLAGS = @check_CFLAGS@
check_main_LDADD = $(top_builddir)/libsigrokdecode.la @check_LIBS@
check_main_CPPFLAGS = $(CPPFLAGS_PYTHON)
+endif
+if HAVE_LIBSIGROK
+bin_PROGRAMS = runtc
+runtc_SOURCES = runtc.c
+runtc_CPPFLAGS = $(CPPFLAGS_PYTHON)
+runtc_LDFLAGS = -L/home/bert/sr/lib -lsigrok -lsigrokdecode
endif