From fbd226c3f70f20fdf3cbfd43a671bf2bcc5d23e6 Mon Sep 17 00:00:00 2001
From: Bert Vermeulen <bert@biot.com>
Date: Tue, 10 Dec 2013 17:17:38 +0100
Subject: Add protocol decoder testing framework.

This adds a tool in the tests directory, called pdtest. It uses the
"test/" directory in every PD directory, if present, to run the
PD against dumps found in the sigrok-dumps repository, and compares
the output against ".output" files in the "test/" directory. The file
"test/test.conf" is used to configure which tests to run.

A separate tool (tests/runtc.c) is used to run the actual decoding and
report output.

To get an overview of the options, run tests/pdtest without any options.
---
 tests/Makefile.am | 7 ++++++-
 1 file changed, 6 insertions(+), 1 deletion(-)

(limited to 'tests/Makefile.am')

diff --git a/tests/Makefile.am b/tests/Makefile.am
index b1ac2bf..8086b9d 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -19,7 +19,6 @@
 ##
 
 if HAVE_CHECK
-
 TESTS = check_main
 
 check_PROGRAMS = ${TESTS}
@@ -37,5 +36,11 @@ check_main_CFLAGS = @check_CFLAGS@
 check_main_LDADD = $(top_builddir)/libsigrokdecode.la @check_LIBS@
 
 check_main_CPPFLAGS = $(CPPFLAGS_PYTHON)
+endif
 
+if HAVE_LIBSIGROK
+bin_PROGRAMS = runtc
+runtc_SOURCES = runtc.c
+runtc_CPPFLAGS = $(CPPFLAGS_PYTHON)
+runtc_LDFLAGS = -L/home/bert/sr/lib -lsigrok -lsigrokdecode
 endif
-- 
cgit v1.2.3-70-g09d2