summaryrefslogtreecommitdiff
path: root/decoders/onewire_transport/Makefile.am
diff options
context:
space:
mode:
authorUwe Hermann <uwe@hermann-uwe.de>2012-07-21 20:37:41 +0200
committerUwe Hermann <uwe@hermann-uwe.de>2012-07-21 21:47:54 +0200
commit19dd61efcc1fe07c6a66f48f74b7926607f3a541 (patch)
tree4669d8fe41fde631107882af32cf615557c23dc7 /decoders/onewire_transport/Makefile.am
parent5d7c5bcca4f770280cd4b58a8ea383fe97cf4a32 (diff)
downloadlibsigrokdecode-19dd61efcc1fe07c6a66f48f74b7926607f3a541.tar.gz
libsigrokdecode-19dd61efcc1fe07c6a66f48f74b7926607f3a541.zip
srd: Rename onewire_transport to maxim_ds28ea00.
It doesn't make sense to have one "generic" onewire_transport PD, as this layer is very much device-specific and such a generic PD would have to contain an accumulation of all possible features and commands and handling code of all existing (now and in the future) 1-Wire devices, which is neither possible nor useful nor elegant. There are (for example) 1-Wire thermometers, RTCs, EEPROMs, special-purpose security chips with passwords/keys, battery monitoring chips, and many many others. They all have a different set of features, commands and command codes, RAM areas/sizes/partitioning/contents, protocols, and so on. Thus, the layering for 1-Wire PD stacks should look like this: onewire_link -> onewire_network -> <specificdevice> Examples: onewire_link -> onewire_network -> maxim_ds28ea00 (special thermometer) onewire_link -> onewire_network -> maxim_ds2431 (1kbit EEPROM) onewire_link -> onewire_network -> maxim_ds2417 (RTC) onewire_link -> onewire_network -> maxim_ds2762 (battery monitor) onewire_link -> onewire_network -> maxim_ds1961s (SHA-1 eCash iButton) and so on... So, renaming onewire_transport to maxim_ds28ea00. The non-DS28EA00 specific code will be dropped and/or moved to other PDs on top of onewire_network later.
Diffstat (limited to 'decoders/onewire_transport/Makefile.am')
-rw-r--r--decoders/onewire_transport/Makefile.am26
1 files changed, 0 insertions, 26 deletions
diff --git a/decoders/onewire_transport/Makefile.am b/decoders/onewire_transport/Makefile.am
deleted file mode 100644
index 982525d..0000000
--- a/decoders/onewire_transport/Makefile.am
+++ /dev/null
@@ -1,26 +0,0 @@
-##
-## This file is part of the sigrok project.
-##
-## Copyright (C) 2012 Uwe Hermann <uwe@hermann-uwe.de>
-##
-## This program is free software; you can redistribute it and/or modify
-## it under the terms of the GNU General Public License as published by
-## the Free Software Foundation; either version 2 of the License, or
-## (at your option) any later version.
-##
-## This program is distributed in the hope that it will be useful,
-## but WITHOUT ANY WARRANTY; without even the implied warranty of
-## MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-## GNU General Public License for more details.
-##
-## You should have received a copy of the GNU General Public License
-## along with this program; if not, write to the Free Software
-## Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA
-##
-
-pkgdatadir = $(DECODERS_DIR)/onewire_transport
-
-dist_pkgdata_DATA = __init__.py onewire_transport.py
-
-CLEANFILES = *.pyc
-