summaryrefslogtreecommitdiff
path: root/decoders/midi/Makefile.am
diff options
context:
space:
mode:
authorUwe Hermann <uwe@hermann-uwe.de>2013-07-18 21:31:47 +0200
committerUwe Hermann <uwe@hermann-uwe.de>2013-10-06 22:08:31 +0200
commit17f5df4f9eb701d6e8203d2953a7c48d3dd55537 (patch)
treea79e10f7217fd3410c0bf329110cf33a90d6b5e2 /decoders/midi/Makefile.am
parentab96960eded15c227208e49007a0b3f65c046aa3 (diff)
downloadlibsigrokdecode-17f5df4f9eb701d6e8203d2953a7c48d3dd55537.tar.gz
libsigrokdecode-17f5df4f9eb701d6e8203d2953a7c48d3dd55537.zip
Add initial MIDI protocol decoder.
This supports a certain number of MIDI messages already, but not yet all of them. More will be added later.
Diffstat (limited to 'decoders/midi/Makefile.am')
-rw-r--r--decoders/midi/Makefile.am26
1 files changed, 26 insertions, 0 deletions
diff --git a/decoders/midi/Makefile.am b/decoders/midi/Makefile.am
new file mode 100644
index 0000000..f45d086
--- /dev/null
+++ b/decoders/midi/Makefile.am
@@ -0,0 +1,26 @@
+##
+## This file is part of the libsigrokdecode project.
+##
+## Copyright (C) 2013 Uwe Hermann <uwe@hermann-uwe.de>
+##
+## This program is free software; you can redistribute it and/or modify
+## it under the terms of the GNU General Public License as published by
+## the Free Software Foundation; either version 2 of the License, or
+## (at your option) any later version.
+##
+## This program is distributed in the hope that it will be useful,
+## but WITHOUT ANY WARRANTY; without even the implied warranty of
+## MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+## GNU General Public License for more details.
+##
+## You should have received a copy of the GNU General Public License
+## along with this program; if not, write to the Free Software
+## Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA
+##
+
+pkgdatadir = $(DECODERS_DIR)/midi
+
+dist_pkgdata_DATA = __init__.py pd.py lists.py
+
+CLEANFILES = *.pyc
+