summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBert Vermeulen <bert@biot.com>2013-12-11 01:21:22 +0100
committerBert Vermeulen <bert@biot.com>2013-12-11 01:21:22 +0100
commitf8c88ebc5b33052de0b88690577af4611aa3709a (patch)
tree075e5a7ac9c81329558c8ac755206bafe645ecb1 /configure.ac
parentfbd226c3f70f20fdf3cbfd43a671bf2bcc5d23e6 (diff)
downloadlibsigrokdecode-f8c88ebc5b33052de0b88690577af4611aa3709a.tar.gz
libsigrokdecode-f8c88ebc5b33052de0b88690577af4611aa3709a.zip
Clean up runtc build.
This only compiles libsigrok into the one target that needs it, instead of slopping it all over the place.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 6 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 1314dea..1728c60 100644
--- a/configure.ac
+++ b/configure.ac
@@ -124,9 +124,13 @@ PKG_CHECK_MODULES([check], [check >= 0.9.4],
AM_CONDITIONAL(HAVE_CHECK, test x"$have_check" = "xyes")
PKG_CHECK_MODULES([libsigrok], [libsigrok >= 0.2.0],
- [have_libsigrok="yes"; CFLAGS="$CFLAGS $libsigrok_CFLAGS";
- LIBS="$LIBS $libsigrok_LIBS"], [have_libsigrok="no"])
+ [have_libsigrok="yes";
+ LIBSIGROK_CFLAGS="$libsigrok_CFLAGS";
+ LIBSIGROK_LIBS="$libsigrok_LIBS"],
+ [have_libsigrok="no"])
AM_CONDITIONAL(HAVE_LIBSIGROK, test x"$have_libsigrok" = "xyes")
+AC_SUBST([LIBSIGROK_CFLAGS])
+AC_SUBST([LIBSIGROK_LIBS])
# Checks for header files.
# These are already checked: inttypes.h stdint.h stdlib.h string.h unistd.h.