summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorUwe Hermann <uwe@hermann-uwe.de>2018-05-17 22:50:45 +0200
committerUwe Hermann <uwe@hermann-uwe.de>2018-05-17 23:00:43 +0200
commitd652ef844d7af968c4b4fe76e477d3d1fed54138 (patch)
treedc565c1bfc4f52bf8eff4527d2dff5298299f5b4 /configure.ac
parent1d757906a2f8c881fcbbd1915420aa80a9d5da36 (diff)
downloadlibsigrokdecode-d652ef844d7af968c4b4fe76e477d3d1fed54138.tar.gz
libsigrokdecode-d652ef844d7af968c4b4fe76e477d3d1fed54138.zip
configure.ac: Add some more compiler warning options.
Add the -Wshadow -Wformat=2 -Wno-format-nonliteral -Wfloat-equal compiler options (supported by both gcc and clang) to get notified of more potential issues in the code.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 5593bc4..7b3fe16 100644
--- a/configure.ac
+++ b/configure.ac
@@ -119,7 +119,7 @@ SR_CHECK_COMPILE_FLAGS([SRD_EXTRA_CFLAGS], [C99], [-std=c99 -c99 -AC99 -qlanglvl
SR_CHECK_COMPILE_FLAGS([SRD_EXTRA_CFLAGS], [visibility], [-fvisibility=hidden])
# Select suitable compiler warning flags.
-SR_ARG_ENABLE_WARNINGS([SRD_WFLAGS], [-Wall], [-Wall -Wextra -Wmissing-prototypes])
+SR_ARG_ENABLE_WARNINGS([SRD_WFLAGS], [-Wall], [-Wall -Wextra -Wmissing-prototypes -Wshadow -Wformat=2 -Wno-format-nonliteral -Wfloat-equal])
# Link against libm, this is required (among other things) by Python.
SRD_EXTRA_LIBS=