summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorUwe Hermann <uwe@hermann-uwe.de>2013-10-16 19:37:44 +0200
committerUwe Hermann <uwe@hermann-uwe.de>2013-10-17 01:51:16 +0200
commit7529cdaad9e9a52c93ed4d21c2fcccaf3313592c (patch)
tree059f8163cced163ed64dfb1d1d80f607afa6c978 /configure.ac
parent7fc7bde666b3c1234e3d9612caa0388381881059 (diff)
downloadlibsigrokdecode-7529cdaad9e9a52c93ed4d21c2fcccaf3313592c.tar.gz
libsigrokdecode-7529cdaad9e9a52c93ed4d21c2fcccaf3313592c.zip
Add a testsuite for libsigrokdecode.
This uses the Check unit testing framework, just like libsigrok. For now, only a few very basic unit tests are included. Invocation: make check
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 12 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index f0dae21..60d9131 100644
--- a/configure.ac
+++ b/configure.ac
@@ -34,7 +34,7 @@ AC_CONFIG_MACRO_DIR([autostuff])
AC_CONFIG_AUX_DIR([autostuff])
# We require at least automake 1.11 (needed for 'silent rules').
-AM_INIT_AUTOMAKE([1.11 -Wall -Werror check-news])
+AM_INIT_AUTOMAKE([1.11 -Wall -Werror check-news color-tests])
m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES([yes])])
m4_ifdef([AM_PROG_AR], [AM_PROG_AR])
@@ -52,6 +52,9 @@ AC_PROG_CPP
AC_PROG_INSTALL
AC_PROG_LN_S
+# Required for per-target flags or subdir-objects with C sources.
+AM_PROG_CC_C_O
+
# Initialize libtool.
LT_INIT
@@ -114,6 +117,12 @@ esac
AC_SUBST(CPPFLAGS_PYTHON)
AC_SUBST(LDFLAGS_PYTHON)
+# The Check unit testing framework is optional. Disable if not found.
+PKG_CHECK_MODULES([check], [check >= 0.9.4],
+ [have_check="yes"; CFLAGS="$CFLAGS $check_CFLAGS";
+ LIBS="$LIBS $check_LIBS"], [have_check="no"])
+AM_CONDITIONAL(HAVE_CHECK, test x"$have_check" = "xyes")
+
# Checks for header files.
# These are already checked: inttypes.h stdint.h stdlib.h string.h unistd.h.
# AC_CHECK_HEADERS([])
@@ -185,6 +194,7 @@ AC_CONFIG_FILES([Makefile
decoders/usb_packet/Makefile
decoders/usb_signalling/Makefile
decoders/xfp/Makefile
+ tests/Makefile
])
AC_OUTPUT
@@ -202,7 +212,7 @@ echo "Detected libraries:"
echo
# Note: This only works for libs with pkg-config integration.
-for lib in "glib-2.0 >= 2.24.0"; do
+for lib in "glib-2.0 >= 2.24.0" "check >= 0.9.4"; do
if `$PKG_CONFIG --exists $lib`; then
ver=`$PKG_CONFIG --modversion $lib`
answer="yes ($ver)"