summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorUwe Hermann <uwe@hermann-uwe.de>2014-01-30 19:19:23 +0100
committerUwe Hermann <uwe@hermann-uwe.de>2014-01-30 19:19:23 +0100
commit4dc2a249c9691da9981c849270267a3dc1096700 (patch)
treeb3232cfad36a56b8294c49b64f8a2a1b054c9517 /configure.ac
parent714f22fe69a79f517fb3b47567b390233987d246 (diff)
downloadlibsigrokdecode-4dc2a249c9691da9981c849270267a3dc1096700.tar.gz
libsigrokdecode-4dc2a249c9691da9981c849270267a3dc1096700.zip
configure.ac: Only check for things we actually use.
Drop checks where we don't use the result (yet). We might bring back some of those once we start actually using the result in the code.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 0 insertions, 15 deletions
diff --git a/configure.ac b/configure.ac
index 12de743..b817142 100644
--- a/configure.ac
+++ b/configure.ac
@@ -134,21 +134,6 @@ AC_SUBST([LIBSIGROK_LIBS])
# These are already checked: inttypes.h stdint.h stdlib.h string.h unistd.h.
AC_CHECK_HEADER([sys/resource.h], [], [build_runtc="no"])
-# Checks for typedefs, structures, and compiler characteristics.
-AC_C_INLINE
-AC_TYPE_INT8_T
-AC_TYPE_INT16_T
-AC_TYPE_INT32_T
-AC_TYPE_INT64_T
-AC_TYPE_UINT8_T
-AC_TYPE_UINT16_T
-AC_TYPE_UINT32_T
-AC_TYPE_UINT64_T
-AC_TYPE_SIZE_T
-
-# Checks for library functions.
-AC_CHECK_FUNCS([memset strtoull])
-
AC_SUBST(DECODERS_DIR, "$datadir/libsigrokdecode/decoders")
AC_SUBST(MAKEFLAGS, '--no-print-directory')
AC_SUBST(AM_LIBTOOLFLAGS, '--silent')