summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGerhard Sittig <gerhard.sittig@gmx.net>2020-02-22 06:09:35 +0100
committerGerhard Sittig <gerhard.sittig@gmx.net>2020-07-18 15:23:40 +0200
commit4342689729bd3ea70209604b34af0a7c641b80cc (patch)
tree338ffd0cba6a25b1ea09142e5f783967e90fae64 /configure.ac
parentc32de941d4eafc6b773b3d8e26e6befe88d580b7 (diff)
downloadlibsigrokdecode-4342689729bd3ea70209604b34af0a7c641b80cc.tar.gz
libsigrokdecode-4342689729bd3ea70209604b34af0a7c641b80cc.zip
configure: add AC_C_CONST to configure.ac
This is inspired by the autobook sections on Windows DLL builds. https://www.sourceware.org/autobook/autobook/autobook_137.html The AC_C_CONST macro improves support for the C language 'const' decoration in case the compiler does not understand it.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d59e0be..3a8b163 100644
--- a/configure.ac
+++ b/configure.ac
@@ -40,6 +40,8 @@ AC_PROG_CC
AC_PROG_INSTALL
AC_PROG_LN_S
+AC_C_CONST
+
# Required for per-target flags or subdir-objects with C sources.
AM_PROG_CC_C_O