summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorUwe Hermann <uwe@hermann-uwe.de>2012-06-19 17:29:18 +0200
committerUwe Hermann <uwe@hermann-uwe.de>2012-06-21 00:07:50 +0200
commit2dc6d41c64a8235308e61b4f9b509c7fecb2b502 (patch)
treee4f9cb630a5853973fa97d65fb75e3b12ba8d763 /configure.ac
parent3cf771a5179d94a156bef1aa95d7e05411dc82e2 (diff)
downloadlibsigrokdecode-2dc6d41c64a8235308e61b4f9b509c7fecb2b502.tar.gz
libsigrokdecode-2dc6d41c64a8235308e61b4f9b509c7fecb2b502.zip
srd: Split USB decoder in two PDs (which stack).
The 'usb_signalling' decoder just decodes symbols from D+/D- levels, handles bit stuffing and outputs the symbols and (potential) packets. The 'usb_protocol' decoder takes that output and tried to parse USB packets from it (SOF, SETUP, IN, OUT, DATA0, and so on). This is the base decoder on top of which various others will stack later on. The two new PDs are work in progress, so we still keep the old 'usb' PD around for a little while, until the two new ones are fully working and well-tested.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index be2946e..ec1a14f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -168,6 +168,8 @@ AC_CONFIG_FILES([Makefile
decoders/uart/Makefile
decoders/uart_dump/Makefile
decoders/usb/Makefile
+ decoders/usb_signalling/Makefile
+ decoders/usb_protocol/Makefile
])
AC_OUTPUT