summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDaniel Elstner <daniel.kitta@gmail.com>2015-09-13 22:10:54 +0200
committerDaniel Elstner <daniel.kitta@gmail.com>2015-09-13 22:10:54 +0200
commitfdfc532ecd49fc3353627ef4a093366e73d6b91a (patch)
tree6511899a719faace7db2d9b806981a9cb65227b6 /Makefile.am
parent367843620d039ad183bc4d7c33d91c316d717621 (diff)
downloadlibsigrokdecode-fdfc532ecd49fc3353627ef4a093366e73d6b91a.tar.gz
libsigrokdecode-fdfc532ecd49fc3353627ef4a093366e73d6b91a.zip
Build: Move _POSIX_C_SOURCE definition to config.h
Do not redefine it though when already set, so that it can be overridden by the user, or indirectly by the compiler settings.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 2bbdb2c..e90e2e4 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -23,7 +23,7 @@ AM_LIBTOOLFLAGS = --silent
GNUMAKEFLAGS = --no-print-directory
DECODERS_DIR = $(pkgdatadir)/decoders
-AM_CPPFLAGS = -D_POSIX_C_SOURCE=200112L -DDECODERS_DIR='"$(DECODERS_DIR)"'
+AM_CPPFLAGS = -DDECODERS_DIR='"$(DECODERS_DIR)"'
# The tests CFLAGS are a superset of the libsigrokdecode CFLAGS.
AM_CFLAGS = $(SRD_EXTRA_CFLAGS) $(SRD_WFLAGS) $(TESTS_CFLAGS)
@@ -70,7 +70,7 @@ tests_main_SOURCES = \
tests/inst.c \
tests/session.c
-tests_main_CPPFLAGS = -D_POSIX_C_SOURCE=200112L -DDECODERS_DIR='"$(abs_top_srcdir)/decoders"'
+tests_main_CPPFLAGS = -DDECODERS_DIR='"$(abs_top_srcdir)/decoders"'
tests_main_LDADD = libsigrokdecode.la $(SRD_EXTRA_LIBS) $(TESTS_LIBS)
MAINTAINERCLEANFILES = ChangeLog