summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorBert Vermeulen <bert@biot.com>2013-12-10 17:17:38 +0100
committerBert Vermeulen <bert@biot.com>2013-12-10 17:22:24 +0100
commitfbd226c3f70f20fdf3cbfd43a671bf2bcc5d23e6 (patch)
tree7372a8e8b359b38a1a542a16fe14dd9058d5bded /Makefile.am
parent4d2c7619ec72728dd01999f20ef1004e018d18a4 (diff)
downloadlibsigrokdecode-fbd226c3f70f20fdf3cbfd43a671bf2bcc5d23e6.tar.gz
libsigrokdecode-fbd226c3f70f20fdf3cbfd43a671bf2bcc5d23e6.zip
Add protocol decoder testing framework.
This adds a tool in the tests directory, called pdtest. It uses the "test/" directory in every PD directory, if present, to run the PD against dumps found in the sigrok-dumps repository, and compares the output against ".output" files in the "test/" directory. The file "test/test.conf" is used to configure which tests to run. A separate tool (tests/runtc.c) is used to run the actual decoding and report output. To get an overview of the options, run tests/pdtest without any options.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index a9460e5..f9bc14d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -39,7 +39,7 @@ libsigrokdecode_la_SOURCES = \
version.c
libsigrokdecode_la_CPPFLAGS = $(CPPFLAGS_PYTHON) \
- -DDECODERS_DIR='"$(DECODERS_DIR)"'
+ -DDECODERS_DIR='"$(DECODERS_DIR)"'
libsigrokdecode_la_LDFLAGS = $(SRD_LIB_LDFLAGS) $(LDFLAGS_PYTHON)
library_includedir = $(includedir)/libsigrokdecode