summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorBert Vermeulen <bert@biot.com>2011-12-04 10:33:02 +0100
committerBert Vermeulen <bert@biot.com>2011-12-04 17:56:56 +0100
commitb2c19614a6c4eaa0170971d1261a1bb25212e277 (patch)
treeb599e5e3795c0b094cd4514820db0c7e761653fd /Makefile.am
parent2b7d0e2bf5147025e9d76d14e266b9905503b957 (diff)
downloadlibsigrokdecode-b2c19614a6c4eaa0170971d1261a1bb25212e277.tar.gz
libsigrokdecode-b2c19614a6c4eaa0170971d1261a1bb25212e277.zip
refactored PD framework, now using new sigrok.Decoder object
This uses the new python unified type/class object API to construct an object for PDs to subclass. The sigrok.Decoder class has a method put() which is implemented as a C function, and receives the PD's object instance as its first parameter.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index e6d0710..1c53631 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -22,7 +22,7 @@ SUBDIRS = decoders
lib_LTLIBRARIES = libsigrokdecode.la
-libsigrokdecode_la_SOURCES = decode.c
+libsigrokdecode_la_SOURCES = controller.c decoder.c util.c
libsigrokdecode_la_CPPFLAGS = $(CPPFLAGS_PYTHON) \
-DDECODERS_DIR='"$(DECODERS_DIR)"'