summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorGerhard Sittig <gerhard.sittig@gmx.net>2021-12-26 08:23:27 +0100
committerGerhard Sittig <gerhard.sittig@gmx.net>2021-12-26 13:45:09 +0100
commit7cfa9f7aa2426c617990f3ecfcabed8765aff46c (patch)
treee3edca5bcd18328b0cd91049a6bbd0aa3c666aa3 /Makefile.am
parentde219b2b77dba06815869823789458581500ca03 (diff)
downloadlibsigrokdecode-7cfa9f7aa2426c617990f3ecfcabed8765aff46c.tar.gz
libsigrokdecode-7cfa9f7aa2426c617990f3ecfcabed8765aff46c.zip
ir_irmp: wrapper lib, add locking and Python threading support
The IRMP core library is not thread safe (known limitation, heritage of the AVR firmware origin). Add a mutex so that calling applications can lock IR decoder core instances. Allow Python threading while waiting for the locks, we can safely assume that this IRMP wrapper is used in the sigrok context which does require Python for decoders. Add my copyright for the non-trivial changes. This implementation uses glib for locking to improve portability, which already is a dependency of the libsigrokdecode component. This version uses belt and suspenders by implementing a constructor as well as adding auto init calls to each of the public API code paths. The client ID is not an essential requirement, but useful during application maintenance.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 9e15c30..32c6dd6 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -64,6 +64,8 @@ libirmp_la_SOURCES = \
irmp/irmpsystem.h \
irmp/irmpprotocols.h
noinst_HEADERS += irmp/irmp.c
+libirmp_la_CFLAGS = $(LIBIRMP_CFLAGS)
+libirmp_la_LIBADD = $(LIBIRMP_LIBS)
libirmp_la_LDFLAGS = -no-undefined -version-info 0:0:0
endif