summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorUwe Hermann <uwe@hermann-uwe.de>2010-04-02 20:18:27 +0200
committerUwe Hermann <uwe@hermann-uwe.de>2010-04-02 20:27:54 +0200
commit1c6fa20f549c0565ce4fae6ddf7d5eb60db2ddea (patch)
tree74dacad1cd78a0d787b8264e5ae9e13866736b7b /Makefile.am
downloadlibsigrokdecode-1c6fa20f549c0565ce4fae6ddf7d5eb60db2ddea.tar.gz
libsigrokdecode-1c6fa20f549c0565ce4fae6ddf7d5eb60db2ddea.zip
Start of code base layout restructuring.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am31
1 files changed, 31 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..6aac2c1
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,31 @@
+##
+## This file is part of the sigrok project.
+##
+## Copyright (C) 2010 Uwe Hermann <uwe@hermann-uwe.de>
+##
+## This program is free software; you can redistribute it and/or modify
+## it under the terms of the GNU General Public License as published by
+## the Free Software Foundation; either version 2 of the License, or
+## (at your option) any later version.
+##
+## This program is distributed in the hope that it will be useful,
+## but WITHOUT ANY WARRANTY; without even the implied warranty of
+## MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+## GNU General Public License for more details.
+##
+## You should have received a copy of the GNU General Public License
+## along with this program; if not, write to the Free Software
+## Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA
+##
+
+SUBDIRS = scripts
+
+lib_LTLIBRARIES = libsigrokdecode.la
+
+libsigrokdecode_la_SOURCES = decode.c
+
+libsigrokdecode_la_CPPFLAGS = $(CPPFLAGS_PYTHON)
+libsigrokdecode_la_LDFLAGS = $(LDFLAGS_PYTHON)
+
+include_HEADERS = sigrokdecode.h
+