summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorUwe Hermann <uwe@hermann-uwe.de>2016-05-24 21:42:02 +0200
committerUwe Hermann <uwe@hermann-uwe.de>2016-05-25 15:14:23 +0200
commit135b790c851c52400279e7c932e1f900d91ae5cc (patch)
treec3bd5bc677c8e66044853bddc0e96cbdcfa2c376 /Makefile.am
parentae2181cd35e84ce81cfe58d2e0e05fdb3dfcb263 (diff)
downloadlibsigrokdecode-135b790c851c52400279e7c932e1f900d91ae5cc.tar.gz
libsigrokdecode-135b790c851c52400279e7c932e1f900d91ae5cc.zip
Move common/ directory into decoders/.
This simplifies cross-platform handling of the Python/decoder paths and module installation/dist a bit and also fixes bug #804.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 2 insertions, 9 deletions
diff --git a/Makefile.am b/Makefile.am
index 1a1074e..a8df8f6 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -23,12 +23,11 @@ AM_LIBTOOLFLAGS = --silent
GNUMAKEFLAGS = --no-print-directory
DECODERS_DIR = $(pkgdatadir)/decoders
-COMMON_DIR = $(pkgdatadir)/common
# Do not hard-code the decoders location on Windows.
if WIN32
AM_CPPFLAGS =
else
-AM_CPPFLAGS = -DDECODERS_DIR='"$(DECODERS_DIR)"' -DCOMMON_DIR='"$(COMMON_DIR)"'
+AM_CPPFLAGS = -DDECODERS_DIR='"$(DECODERS_DIR)"'
endif
# The tests CFLAGS are a superset of the libsigrokdecode CFLAGS.
@@ -89,20 +88,14 @@ ChangeLog:
dist-hook: ChangeLog
$(MKDIR_P) $(distdir)/tools
cp ${top_srcdir}/tools/install-decoders $(distdir)/tools
- $(MKDIR_P) $(distdir)/common
- cp -a ${top_srcdir}/common $(distdir)
$(MKDIR_P) $(distdir)/decoders
${top_srcdir}/tools/install-decoders -i ${top_srcdir}/decoders \
-o $(distdir)/decoders
-install-common:
- $(MKDIR_P) $(DESTDIR)$(COMMON_DIR)
- cp -a ${top_srcdir}/common $(DESTDIR)$(pkgdatadir)
-
install-decoders:
$(MKDIR_P) $(DESTDIR)$(DECODERS_DIR)
$(PYTHON3) ${top_srcdir}/tools/install-decoders \
-i ${top_srcdir}/decoders -o $(DESTDIR)$(DECODERS_DIR)
-install-data-hook: install-common install-decoders
+install-data-hook: install-decoders