summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGerhard Sittig <gerhard.sittig@gmx.net>2022-02-21 23:13:38 +0100
committerGerhard Sittig <gerhard.sittig@gmx.net>2022-02-21 23:13:38 +0100
commit7d8cfad064c9da721af62b54d4743938e8be35e8 (patch)
treebacd4d1c3fc5df9076ea71a312323ce9408aeea9 /configure.ac
parent14e38a009d0ed7c6e3f1cb2f725b0d5f00331638 (diff)
downloadsigrok-test-7d8cfad064c9da721af62b54d4743938e8be35e8.tar.gz
sigrok-test-7d8cfad064c9da721af62b54d4743938e8be35e8.zip
configure.ac: check for python3-embed
Check for the python3-embed availability to eliminate the necessity to list all currently existing minor versions and keep catching up as more are released. Break the long text line with the many Python packages.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index e87ca0c..f0c6753 100644
--- a/configure.ac
+++ b/configure.ac
@@ -59,7 +59,10 @@ SR_PKG_CHECK_SUMMARY([st_pkglibs_summary])
# first, since usually only that variant will add "-lpython3.8".
# https://docs.python.org/3/whatsnew/3.8.html#debug-build-uses-the-same-abi-as-release-build
SR_PKG_CHECK([python3], [ST_PKGLIBS],
- [python-3.8-embed], [python-3.8 >= 3.8], [python-3.7 >= 3.7], [python-3.6 >= 3.6], [python-3.5 >= 3.5], [python-3.4 >= 3.4], [python-3.3 >= 3.3], [python-3.2 >= 3.2], [python3 >= 3.2])
+ [python-3.8-embed], [python3-embed],
+ [python-3.8 >= 3.8], [python-3.7 >= 3.7], [python-3.6 >= 3.6],
+ [python-3.5 >= 3.5], [python-3.4 >= 3.4], [python-3.3 >= 3.3],
+ [python-3.2 >= 3.2], [python3 >= 3.2])
AS_IF([test "x$sr_have_python3" = xno],
[AC_MSG_ERROR([Cannot find Python 3 development headers.])])