summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorUwe Hermann <uwe@hermann-uwe.de>2020-03-21 14:39:10 +0100
committerUwe Hermann <uwe@hermann-uwe.de>2020-03-21 14:39:10 +0100
commit2064a252fe5d48a565121c41f918f624518df991 (patch)
tree63c126395f91e7452f66bcfb2b9942e65c2f2277 /configure.ac
parentb502bf25665c0dd8e3ae51ec1279b18330990b69 (diff)
downloadsigrok-test-2064a252fe5d48a565121c41f918f624518df991.tar.gz
sigrok-test-2064a252fe5d48a565121c41f918f624518df991.zip
configure.ac: Add support for Python 3.8.
This fixes build issues when using Python 3.8.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index f0520de..4f65901 100644
--- a/configure.ac
+++ b/configure.ac
@@ -54,8 +54,11 @@ ST_PKGLIBS=
SR_PKG_CHECK_SUMMARY([st_pkglibs_summary])
# Python 3 is always needed.
+# Starting with Python 3.8 we need to check for "python-3.8-embed"
+# first, since usually only that variant will add "-lpython3.8".
+# https://docs.python.org/3/whatsnew/3.8.html#debug-build-uses-the-same-abi-as-release-build
SR_PKG_CHECK([python3], [ST_PKGLIBS],
- [python3 >= 3.2], [python-3.5 >= 3.5], [python-3.4 >= 3.4], [python-3.3 >= 3.3], [python-3.2 >= 3.2])
+ [python-3.8-embed], [python-3.8 >= 3.8], [python-3.7 >= 3.7], [python-3.6 >= 3.6], [python-3.5 >= 3.5], [python-3.4 >= 3.4], [python-3.3 >= 3.3], [python-3.2 >= 3.2], [python3 >= 3.2])
AS_IF([test "x$sr_have_python3" = xno],
[AC_MSG_ERROR([Cannot find Python 3 development headers.])])