Age | Commit message (Collapse) | Author | |
---|---|---|---|
2017-06-05 | Rename maxim_ds28ea00 to ds28ea00. | Uwe Hermann | |
None of the other PDs have a vendorname in the PD name. | |||
2017-01-07 | license: remove FSF postal address from boiler plate license text | Gerhard Sittig | |
Remove the FSF postal address as it might change (it did in the past). Reference the gnu.org website instead which is more stable. | |||
2014-10-13 | All PDs: Only import the 'Decoder' object. | Uwe Hermann | |
Anything else in the pd.py files doesn't have to be imported/exposed. | |||
2014-07-15 | All PDs: Minor whitespace and consistency fixes. | Uwe Hermann | |
- No newlines at the end of files. - No trailing ';' characters. - Comparison with None: Use 'is None' or 'is not None'. - Comparison with True/False: Use 'if cond:' or 'if not cond:'. - Various minor whitespace fixes. | |||
2014-01-28 | All PDs: Improve/fix descriptions. | Uwe Hermann | |
2013-04-23 | GPL headers: Use correct project name. | Uwe Hermann | |
2012-11-24 | All PDs: Name the files pd.py consistently. | Uwe Hermann | |
The Python module name is determined by the directory name (e.g. dcf77), the *.py file names in that directory don't matter and can be kept consistent. | |||
2012-07-21 | srd: maxim_ds28ea00: Cosmetics, cleanups. | Uwe Hermann | |
2012-07-21 | srd: maxim_ds28ea00: Fix to only handle DS28EA00. | Uwe Hermann | |
2012-07-21 | srd: Rename onewire_transport to maxim_ds28ea00. | Uwe Hermann | |
It doesn't make sense to have one "generic" onewire_transport PD, as this layer is very much device-specific and such a generic PD would have to contain an accumulation of all possible features and commands and handling code of all existing (now and in the future) 1-Wire devices, which is neither possible nor useful nor elegant. There are (for example) 1-Wire thermometers, RTCs, EEPROMs, special-purpose security chips with passwords/keys, battery monitoring chips, and many many others. They all have a different set of features, commands and command codes, RAM areas/sizes/partitioning/contents, protocols, and so on. Thus, the layering for 1-Wire PD stacks should look like this: onewire_link -> onewire_network -> <specificdevice> Examples: onewire_link -> onewire_network -> maxim_ds28ea00 (special thermometer) onewire_link -> onewire_network -> maxim_ds2431 (1kbit EEPROM) onewire_link -> onewire_network -> maxim_ds2417 (RTC) onewire_link -> onewire_network -> maxim_ds2762 (battery monitor) onewire_link -> onewire_network -> maxim_ds1961s (SHA-1 eCash iButton) and so on... So, renaming onewire_transport to maxim_ds28ea00. The non-DS28EA00 specific code will be dropped and/or moved to other PDs on top of onewire_network later. |