summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 47482c2..a57cea5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -37,6 +37,8 @@ AH_TOP([#ifndef SRD_CONFIG_H
#define SRD_CONFIG_H /* To stop multiple inclusions. */])
AH_BOTTOM([#endif /* SRD_CONFIG_H */])
+AC_CANONICAL_HOST
+
# Checks for programs.
AC_PROG_CC
AC_PROG_INSTALL
@@ -45,6 +47,9 @@ AC_PROG_LN_S
# Required for per-target flags or subdir-objects with C sources.
AM_PROG_CC_C_O
+# Get compiler versions.
+SR_PROG_VERSION([$CC], [srd_cc_version])
+
# Initialize libtool.
LT_INIT
@@ -138,7 +143,10 @@ libsigrokdecode configuration summary:
- Prefix.......................... $prefix
- Building on..................... $build
- Building for.................... $host
+
+Compile configuration:
- C compiler...................... $CC
+ - C compiler version.............. $srd_cc_version
- C compiler flags................ $CFLAGS
- Additional C compiler flags..... $SRD_EXTRA_CFLAGS
- C compiler warnings............. $SRD_WFLAGS