summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorBert Vermeulen <bert@biot.com>2013-12-11 12:50:38 +0100
committerBert Vermeulen <bert@biot.com>2013-12-11 12:50:38 +0100
commitb74823812d4106bfafc4a7fef1d4a141dac58519 (patch)
tree6b2f53c65022a06fe8181517250525bcd54a8bde /tests/Makefile.am
parent2c53ea9310728f451a7c69c49d376b727ff08ff3 (diff)
downloadlibsigrokdecode-b74823812d4106bfafc4a7fef1d4a141dac58519.tar.gz
libsigrokdecode-b74823812d4106bfafc4a7fef1d4a141dac58519.zip
runtc: Make sure to test this set of decoders, not the installed ones.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 7841f05..5739a03 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -41,6 +41,7 @@ endif
if HAVE_LIBSIGROK
bin_PROGRAMS = runtc
runtc_SOURCES = runtc.c
-runtc_CPPFLAGS = $(CPPFLAGS_PYTHON) $(LIBSIGROK_CFLAGS)
+runtc_CPPFLAGS = $(CPPFLAGS_PYTHON) $(LIBSIGROK_CFLAGS) \
+ -DDECODERS_DIR='"$(abs_top_builddir)/decoders"'
runtc_LDFLAGS = $(LIBSIGROK_LIBS) -L$(top_builddir) -lsigrokdecode
endif