summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorBert Vermeulen <bert@biot.com>2013-12-11 18:36:42 +0100
committerBert Vermeulen <bert@biot.com>2013-12-11 18:36:42 +0100
commit554a49f9df0ee8c57d7fae64515cf57d622b0511 (patch)
tree34fb8309bd2ca2770f8366fefd75550b1f118a99 /tests/Makefile.am
parentea81b49a3ca4fff4994693d30045d51b86181e32 (diff)
downloadlibsigrokdecode-554a49f9df0ee8c57d7fae64515cf57d622b0511.tar.gz
libsigrokdecode-554a49f9df0ee8c57d7fae64515cf57d622b0511.zip
check: Make sure to test this set of decoders, not the installed ones.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am8
1 files changed, 2 insertions, 6 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 5739a03..e70b301 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -20,9 +20,7 @@
if HAVE_CHECK
TESTS = check_main
-
check_PROGRAMS = ${TESTS}
-
check_main_SOURCES = \
$(top_builddir)/libsigrokdecode.h \
check_main.c \
@@ -30,12 +28,10 @@ check_main_SOURCES = \
check_decoder.c \
check_inst.c \
check_session.c
-
check_main_CFLAGS = @check_CFLAGS@
-
check_main_LDADD = $(top_builddir)/libsigrokdecode.la @check_LIBS@
-
-check_main_CPPFLAGS = $(CPPFLAGS_PYTHON)
+check_main_CPPFLAGS = $(CPPFLAGS_PYTHON) \
+ -DDECODERS_DIR='"$(abs_top_builddir)/decoders"'
endif
if HAVE_LIBSIGROK