summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDaniel Elstner <daniel.kitta@gmail.com>2015-09-13 22:10:54 +0200
committerDaniel Elstner <daniel.kitta@gmail.com>2015-09-13 22:10:54 +0200
commitfdfc532ecd49fc3353627ef4a093366e73d6b91a (patch)
tree6511899a719faace7db2d9b806981a9cb65227b6 /configure.ac
parent367843620d039ad183bc4d7c33d91c316d717621 (diff)
downloadlibsigrokdecode-fdfc532ecd49fc3353627ef4a093366e73d6b91a.tar.gz
libsigrokdecode-fdfc532ecd49fc3353627ef4a093366e73d6b91a.zip
Build: Move _POSIX_C_SOURCE definition to config.h
Do not redefine it though when already set, so that it can be overridden by the user, or indirectly by the compiler settings.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 6 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index a57cea5..53e8bc1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -33,10 +33,6 @@ AM_INIT_AUTOMAKE([1.11 -Wall -Werror no-define subdir-objects check-news color-t
AM_SILENT_RULES([yes])
m4_ifdef([AM_PROG_AR], [AM_PROG_AR])
-AH_TOP([#ifndef SRD_CONFIG_H
-#define SRD_CONFIG_H /* To stop multiple inclusions. */])
-AH_BOTTOM([#endif /* SRD_CONFIG_H */])
-
AC_CANONICAL_HOST
# Checks for programs.
@@ -47,6 +43,12 @@ AC_PROG_LN_S
# Required for per-target flags or subdir-objects with C sources.
AM_PROG_CC_C_O
+# Set the standard the C library headers should conform to.
+AH_VERBATIM([_POSIX_C_SOURCE], [/* The targeted POSIX standard. */
+#ifndef _POSIX_C_SOURCE
+# define _POSIX_C_SOURCE 200112L
+#endif])
+
# Get compiler versions.
SR_PROG_VERSION([$CC], [srd_cc_version])