summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorUwe Hermann <uwe@hermann-uwe.de>2015-02-28 14:18:56 +0100
committerUwe Hermann <uwe@hermann-uwe.de>2015-04-01 00:21:53 +0200
commitc052046717c09758bbdf62819e0029dddcae7159 (patch)
tree20d3d294cb42da0a92c498cd89c8bd7e42c7c634 /Makefile.am
parent7c139a54d14979f832c53d6f7fae7d415ca41a74 (diff)
downloadlibsigrokdecode-c052046717c09758bbdf62819e0029dddcae7159.tar.gz
libsigrokdecode-c052046717c09758bbdf62819e0029dddcae7159.zip
unit tests: Drop unneeded check_ filename prefix.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am20
1 files changed, 10 insertions, 10 deletions
diff --git a/Makefile.am b/Makefile.am
index 398103b..3a50400 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -50,19 +50,19 @@ pkgconfig_DATA = libsigrokdecode.pc
EXTRA_DIST = Doxyfile HACKING contrib/sigrok-logo-notext.png
if HAVE_CHECK
-TESTS = tests/check_main
+TESTS = tests/main
check_PROGRAMS = ${TESTS}
-tests_check_main_SOURCES = \
+tests_main_SOURCES = \
libsigrokdecode.h \
tests/lib.h \
- tests/check_main.c \
- tests/check_core.c \
- tests/check_decoder.c \
- tests/check_inst.c \
- tests/check_session.c
-tests_check_main_CFLAGS = $(AM_CFLAGS) @check_CFLAGS@
-tests_check_main_LDADD = $(top_builddir)/libsigrokdecode.la @check_LIBS@
-tests_check_main_CPPFLAGS = $(CPPFLAGS_PYTHON) \
+ tests/main.c \
+ tests/core.c \
+ tests/decoder.c \
+ tests/inst.c \
+ tests/session.c
+tests_main_CFLAGS = $(AM_CFLAGS) @check_CFLAGS@
+tests_main_LDADD = $(top_builddir)/libsigrokdecode.la @check_LIBS@
+tests_main_CPPFLAGS = $(CPPFLAGS_PYTHON) \
-DDECODERS_DIR='"$(abs_top_srcdir)/decoders"'
endif