summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDaniel Elstner <daniel.kitta@gmail.com>2015-10-03 14:17:07 +0200
committerDaniel Elstner <daniel.kitta@gmail.com>2015-10-03 14:17:07 +0200
commit583001b3f16795abd24278fbb2e5232a7ca27fb0 (patch)
tree5bf8f92bd4fdc9141107ae065fd0c64950930fa4 /Makefile.am
parent40c6ac1d3fbded276dcbff23e8bc099896ab2fb5 (diff)
downloadlibsigrokdecode-583001b3f16795abd24278fbb2e5232a7ca27fb0.tar.gz
libsigrokdecode-583001b3f16795abd24278fbb2e5232a7ca27fb0.zip
build: Do not hard-code decoders location on Windows
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 02f76d9..cd93059 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -23,7 +23,12 @@ AM_LIBTOOLFLAGS = --silent
GNUMAKEFLAGS = --no-print-directory
DECODERS_DIR = $(pkgdatadir)/decoders
+# Do not hard-code the decoders location on Windows.
+if WIN32
+AM_CPPFLAGS =
+else
AM_CPPFLAGS = -DDECODERS_DIR='"$(DECODERS_DIR)"'
+endif
# The tests CFLAGS are a superset of the libsigrokdecode CFLAGS.
AM_CFLAGS = $(SRD_EXTRA_CFLAGS) $(SRD_WFLAGS) $(TESTS_CFLAGS)