summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorUwe Hermann <uwe@hermann-uwe.de>2014-08-16 18:43:51 +0200
committerUwe Hermann <uwe@hermann-uwe.de>2014-08-16 21:36:16 +0200
commit11bd6317ec8d00b3a421516c2e9747a8f7a551ea (patch)
treec63d2ec9d0a4fe1e27cc2bf7d69daa062227a68f /Makefile.am
parent98c47d1107c0f0509cb7e40f2805286e1319afef (diff)
downloadlibsigrokdecode-11bd6317ec8d00b3a421516c2e9747a8f7a551ea.tar.gz
libsigrokdecode-11bd6317ec8d00b3a421516c2e9747a8f7a551ea.zip
configure.ac: Use AM_CFLAGS instead of CFLAGS.
CFLAGS, CPPFLAGS, LDFLAGS and so on are so-called "user variables" and are meant for users of the package to use/override. The package itself should not set or modify them in any way. Instead, the "shadow variables" such as AM_CFLAGS, AM_CPPFLAGS, AM_LDFLAGS and so on, can be modified by the package.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index df8fb86..41054b2 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -60,7 +60,7 @@ tests_check_main_SOURCES = \
tests/check_decoder.c \
tests/check_inst.c \
tests/check_session.c
-tests_check_main_CFLAGS = @check_CFLAGS@
+tests_check_main_CFLAGS = $(AM_CFLAGS) @check_CFLAGS@
tests_check_main_LDADD = $(top_builddir)/libsigrokdecode.la @check_LIBS@
tests_check_main_CPPFLAGS = $(CPPFLAGS_PYTHON) \
-DDECODERS_DIR='"$(abs_top_builddir)/decoders"'